Edit

Read(428) Label: edit,

This section illustrates operations and applications of items under Edit menu.

Undo

You can undo the last operation through this item.

Click Edit -> Undo, or press Ctrl+Z to cancel the last operation.

For instance, content of a cell is “ReportLite” and the font size was 12 pt (as figure 1.3.1-1 shows), but then the font size is changed to 26 pt (as figure 1.3.1-2 shows). Now you want to change the font size back to 12 pt. To do this, just click Edit -> Undo (as figure 1.3.1-3 shows).

 

Redo

You can recover the status before performing undo through this item.

If you want to cancel the undo operation, click Edit -> Redo, or press Ctrl+Y to go back to the status before undo.

For instance, enter “ReportLite” in a cell and set font size as 12pt (as figure 1.3.2-1 shows), and then change the font size to 26pt (as figure 1.3.2-2 shows). Click Edit -> Undo to change the font size back to 12pt (as figure 1.3.2-3 shows). Then if you want to change it to 26pt again, just click Edit -> Redo (as figure 1.3.2-4 shows).

 

Cut

This item is used to cut information of the selected cell(s) or of all cells of the selected row(s)/column(s) for Paste.

Select information to be cut, and click Edit -> Cut, or Right-click menu -> Cut, or press Ctrl+X to perform the cut operation, as the following figure shows:

 

Note: You cannot cut part of a merge cell.

 

Copy

This item is used to copy information of the selected cell(s) or of all cells of the selected row(s)/column(s) for Paste.

Select information to be copied, and click Edit -> Copy, or Right-click menu -> Copy, or press Ctrl+C to perform the copy operation, as the following figure shows:

 

Paste

This item is used to paste the cut or copied content in a position the mouse pointer is placed.

Specify the postion at which the cut or copied content will be pasted, and click Edit -> Paste or Right-click menu -> Paste or press Ctrl+V to perform the paste operation.

 

Insert

This series of items include Insert Row/Column/Cell, Append Row/Column/Cell, Local Report, Rows/Columns.

Insert Row

Through this item, you can insert a row before a selected row or cell.

Select a row or a cell in a row, and click Edit -> Insert -> Insert Row or Right-click menu -> Insert Row or press Ctrl+Enter to insert a row before the selected position. As the following figure shows, select the 2nd row:

 

Insert Column

Through this item, you can insert a column before a selected column or cell.

Select a row or a cell in a row, and click Edit -> Insert -> Insert Column or Right-click menu -> Insert Column or press Ctrl+Shift+Insert to insert a column before the selected position. As the following figure shows, select the 1st column:

 

Append Row

Through this item, you can add a row after the last row of a report.

Click Edit -> Insert -> Append Row or Right-click menu -> Append Row or press Alt+Enter to add a row after the last row. As the following figure shows, select the 2nd row:

 

Append Column

Through this item, you can add a column after the last column of a report.

Click Edit -> Insert -> Append Column or Right-click menu -> Append Column or press Alt+Shift+Insert to add a column after the last column. As the following figure shows, select the 1st column:

 

Insert Cell

Through this item, you can insert a cell before a selected cell.

Select a cell, and click Edit -> Insert -> Insert Cell or press Ctrl+Insert to insert a cell before the selected position. As the following figure shows, select A2:

 

Append Cell

Through this item, you can add a cell after a selected cell.

Click Edit -> Insert -> Append Cell or press Alt +Insert to add a cell after the selected cell. As the following figure shows, select A2:

 

Local Report

Some organizations probably have consistent appearance and style for their report templates and require that new reports be created based on the existing template. In this case users need to insert the report at a certain position of the template.

The “Local Report” item is for inserting a grid report, a crosstab report or a grouped report in a certain cell of the template through wizard.

Select a cell at which a report will be inserted and click Edit -> Insert -> Local Report to get the following wizard:

On the above dialog, select data set for the to-be-inserted report, click “Next” button and select a report type (grid report, crosstab report or grouped report). Then the wizard will lead you through creating a report according to your choice:

Rows

Through this item, you can insert a row zone having rows of a different type.

Click Edit -> Insert -> Rows, select a row type and the number of rows to be inserted on the pop-up “Insert Type” dialog, and click “OK”, as the following shows:

 

Columns

Through this item, you can insert a column zone having columns of a different type.

Click Edit -> Insert -> Columns, select a column type and the number of columns to be inserted on the pop-up “Insert Type” dialog, and click “OK”, as the following shows:

 

Delete

This series of items include Delete Row/Column/Cell operations.

Delete Row

Through this item, you can delete a selected row or the row containing a selected cell.

Select a row, and click Edit -> Delete -> Delete Row or Right-click menu -> Delete Row or press Shift+Delete to delete the selected row. As the following figure shows, select the 2nd row:

 

Delete Column

Through this item, you can delete a selected column or the column containing a selected cell.

Select a column, and click Edit -> Delete -> Delete Column or Right-click menu -> Delete Column or press Ctrl+Shift+Delete to delete the selected column. As the following figure shows, select the 2nd column:

 

Delete Previous Cell

Through this item, you can delete a cell before a selected cell.

Click Edit -> Delete -> Delete Previous Cell or press Ctrl+Backspace to delete the cell before the selected cell. As the following figure shows, select B2:

 

Clear

This series of menu items include Set as Blank, Reset Cell, Clear Format, Clear Content, and Clear Image Layer.

Set as Blank

Through this item, you can set cells of certain rows/columns or certain cells as blank. A blank cell does not store any property information, but is only for holding the place, ensuring that the report is always a complete rectangle. It almost does not take up the memory space. As every report has a rectangular structure, we cannot just delete a cell from it but we can set useless cells as blank. A blank cell represents null in the memory and does not use any memory resource.

Select the target cell or cells, and click Edit -> Clear -> Set as Blank or right-click menu -> Set as Blank or press Ctrl+D to change them into blank cells. As the following figure shows, select A2:

 

Reset Cell

Through this item, you can set a selected cell as an initial cell. An initial cell is one that has properties set in Tools -> Options -> Initial Property, as the following figure shows:

An initial cell isn’t a blank cell. The latter does not store any property information but is only used to hold the place in order to make sure the report is always a complete rectangle. It almost does not use any memory space. An initial cell, however, stores property information that is configure in Tools -> Options -> Initial properties.

Select a target cell, and click Edit -> Clear -> Reset Cell or right-click menu -> Reset Cell to set the cell as the initial cell. Here the initial cell has default properties the system specifies. As the following figure shows, select A1

 

Clear Format

Through this item, you can clear the formatting information in the selected cell(s) or in all cells of the selected row(s)/column(s).

Click primary cell of a row or a column or select one or more cells, and click Edit -> Clear -> Clear Format or right-click menu -> Clear Format to delete their formats. As the following figure shows, select A1:

 

Clear Content

Through this item, you can clear the contents of in the selected cell(s) or in all cells of the selected row(s)/column(s).

Click primary cell of a row or a column or select one or more cells, and click Edit -> Clear -> Clear Content or right-click menu -> Clear Content or press Delete to delete their contents. As the following figure shows, select A1:

 

Clear Image Layer

Through this item, you can clear existing image layers from cells.

Select one or more cells for which image layer is already configured, and click Edit -> Clear -> Clear Image Layer or through Right-click menu -> Clear Image Layer to delete their image layer property.

 

Move

This series of menu items include Move Row/Column/Cell operations.

Move Row Up

Through this item, you can move up a selected row of a row holding the selected cell.

Select a row or a cell in a row, and click Edit -> Move -> Move Row Up or press Ctrl+Alt+Up to move up the row. As the following figure shows, select B2:

 

Move Row Down

Through this item, you can move down a selected row of a row holding the selected cell.

Select a row or a cell in a row, and click Edit -> Move -> Move Row Down or press Ctrl+Alt+Down to move down the row. As the following figure shows, select A1:

 

Move Column Left

Through this item, you can move a selected column of a column holding the selected cell leftward.

Select a column or a cell in a column, and click Edit -> Move -> Move Column Left or press Ctrl+Alt+Left to move the column leftward. As the following figure shows, select B2:

 

Move Column Right

Through this item, you can move a selected column of a column holding the selected cell rightward.

Select a column or a cell in a column, and click Edit -> Move -> Move Column Right or press Ctrl+Alt+Right to move the column rightward. As the following figure shows, select A2:

 

Move Cell Up

Through this item, you can move up a selected cell.

Select a cell, and click Edit -> Move -> Move Cell Up or press Alt+Up to move up the cell.

Move Cell Down

Through this item, you can move down a selected cell.

Select a cell, and click Edit -> Move -> Move Cell Down or press Alt+Down to move down the cell.

Move Cell Left

Through this item, you can move a selected cell leftward.

Select a cell, and click Edit -> Move -> Move Cell Left or press Alt+Left to move the cell leftward.

Move Cell Right

Through this item, you can move a selected cell rightward.

Select a cell, and click Edit -> Move -> Move Cell Right or press Alt+Right to move the cell rightward.

 

Find

This item is for finding the specified content in the report.

Click Edit -> Find or press Ctrl+F to get the following dialog:

Enter the content you want to find in “Find what” box, check “Case sensitive” or “Whole words only” and select an option under “Look in”, and click “Search” button. Each click will select and display the cell containing the target content.

 

Replace

This item is for replacing the specified content of the report with other content.

Click Edit -> Replace or press Ctrl+R to get the “Find” dialog. Enter the content you want to find in “Find what” box and the content with which you want to replace it in “Replace with” box, check “Case sensitive” or “Whole words only” and select an option under “Look in”, and click “Replace” button. Each click will replace an eligible target. Click “Replace All” to replace all targets at once.